How can we improve our languages?

Automatically capitalize the letter "I" when it's all alone.

When you're just typing the letter I as in speaking in the first person, having the I automatically capitalize. I use the enter a space after hitting spacebar and because of that the letter I is always lowercase when by itself.

364 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Michael WarningMichael Warning shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    17 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Go to Settings, Advanced, then click on "Spacebar completion mode". Select complete the current word. When you type "i", it should predict "I". Next, hit the spacebar and it should auto capitalize the "i".

      • Berit Marie AlvestrandBerit Marie Alvestrand commented  ·   ·  Flag as inappropriate

        I use Norwegian and English every other email I send, and auto capitalization of the I drives me crazy! Can't I just have the option of turning it off?

      • Iain CrazeIain Craze commented  ·   ·  Flag as inappropriate

        Yes, i want the letter i to automatically capitalise when standing alone in UK English, please (which it hasn't done when typing this!).

      • HanHan commented  ·   ·  Flag as inappropriate

        Can't this simply be a separate checkbox in the settings, along with being tied to specific languages? This seems like the only frustrating thing about using Swiftkey.

      • JesusJesus commented  ·   ·  Flag as inappropriate

        This simple issue has yet to be addressed for the English (US) pack in the newest version of SK.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Had this been corrected yet? I have the latest version and this still happens constantly to me. I can think of no reason a stand alone i would need to ever be lowercase.

      • Krabbe GurgelKrabbe Gurgel commented  ·   ·  Flag as inappropriate

        No. You should capitalize it yourself. This destroys Scandinavian language, where the preposition i (=in) is the most common word.

      • SveinungSveinung commented  ·   ·  Flag as inappropriate

        I just want to add myself to the list of people that finds auto capitalizing "I" in non-english languages a little tiring. I usually type norwegian, but like to have the english dictionary available at the same time.

      • CurtCurt commented  ·   ·  Flag as inappropriate

        How is it possible some people have it not capitalize when when they want it to, and for others it doesn't when they do?

      • RogersRogers commented  ·   ·  Flag as inappropriate

        Please stop capitalizing the "i"-letter! In Norwegian, "i" means "inn". This lett should NOT be capitalized in Norwegian. Now I have to make this letter lowercase every time I write it in Norwegian, which is often.. Could you please learn from me correcting it every time, or make the capitilazation optional?

      • RaeRae commented  ·   ·  Flag as inappropriate

        PLEASE make this optional; in my informal typing (text messages, facebook posts, etc.) I use a lowercase "I," as in "i love you," "i'll go," "i'd like to," etc. Even though I have AutoCaps disabled, it always predicts the capital and never lowercase, meaning for "i'll" I have to press i key, long press apostrophe, press l key, press l key, and even STILL press the "prediction" of what I actually typed, as capitalized is what it still wants to do.

      • AnonymousAnonymous commented  ·   ·  Flag as inappropriate

        I use SwiftKey in Norwegian and English. The letter I is automatically capitalized, so I gave the opposite problem when typing Norwegian.

      • Yasser SaeedYasser Saeed commented  ·   ·  Flag as inappropriate

        Agree.. The letter i should always be automatically capitalized in English mode.... It's frustrating now, so please fix it. Thanks.

      • Mikko RantalainenMikko Rantalainen commented  ·   ·  Flag as inappropriate

        I like this idea as long as SwiftKey X keeps enough statistics about *currently* typed input to not mess with my text if the current input language is not English. SwiftKey X already supports inputting mixed languages and feature such as this should not cripple that feature.

      • AdamAdam commented  ·   ·  Flag as inappropriate

        This makes total sense if you're using only English. If not, auto capitalization of every occurance of "I" may cause problems. I use SwiftKey specifically because it allows me to use three languages at once - English, Polish and Czech. In Polish the letter "i" means "and", and should be lowercase when used in the middle of the sentence, so I end up decapitalizing it manually every time... Wouldn't it be possible for SwiftKey to learn that I'm doing it and start suggesting lowercase "i" with higher priority?

      • Rusty83Rusty83 commented  ·   ·  Flag as inappropriate

        If so it should be made an optional thing, as we have a word in Danish "i" meaning "in" spelled in lower case.

      Language model feedback: English (US) - Suggestions

      Feedback and Knowledge Base