What is your SwiftKey bug?

Can't type URL's

Try typing www.hcss-gb.ca on a Samsung galaxy S in the email app. Talk about frustrating. Can you please make this app url aware so it doesn't. .. Them up!

50 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Martin Stepanek Martin Stepanek shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    Cary SchwartzmanCary Schwartzman shared a merged idea: Web address / URL entry is difficult  ·   · 

    11 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • JPJP commented  ·   ·  Flag as inappropriate

        It's an easy fix guys. Relax already. Just press shift so it starts as "www" and NOT "Www". Works on and messaging app at the start of every sentence.

        Your Welcome

      • Martin HayesMartin Hayes commented  ·   ·  Flag as inappropriate

        Start typing url, enter full stop, back space, start typing url again, enter full stop, back space again , enter full url, tap the screen to select wrongly inserted space, delete space, find next wrongly inserted space, delete space, you're done.

      • Paul McClellanPaul McClellan commented  ·   ·  Flag as inappropriate

        Until I ran into this issue, SwiftKey was SOOO much faster/better than Swype. However the frustration in trying to simply enter a URL, a frequent/common task, makes me want to go back to Swype. I'm astonished that this deficiency has persisted for longer than a year - it can't be that resource-intensive to at least make SwiftKey aware that the carat is inside a browser's URL field.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Ok, to avoid this really, REALLY annoying situation you should:

        1) Type the main word in the URL (eg. boingboing)
        2) Select the suggestion in the top left corner of the 'suggestion area'.
        3) Press the period - it will automatically give you a space - simply backspace once, and type in .com

      • ChadChad commented  ·   ·  Flag as inappropriate

        Worst keyboard ever when trying to type a URL! I want a refund!!

      • sqlprosqlpro commented  ·   ·  Flag as inappropriate

        I hoped there was already solution but after looking at this page am bit ....
        i was just trying to type url and it was so frustrating and had to type several times before i could actually enter simple URL ! may be a quick short cut needed to temporarily disable autosuggestion for e.g. hitting shift and change it to lower case may be ?

      • Fabian DüngelFabian Düngel commented  ·   ·  Flag as inappropriate

        I totally agree. I have massive problems, typing in address.co.uk for example because the dot finishes the word it thinks it should have become. Any suggestions how to fix this?

      • Matt MoranMatt Moran commented  ·   ·  Flag as inappropriate

        Needs a button to suspend autocorrect. Especially annoying entering passwords that involve punctuation.

      • MackenzeMackenze commented  ·   ·  Flag as inappropriate

        Yes, I agree...this is ridiculous not being able to type a url without the damn auto-correct

      • John FosterJohn Foster commented  ·   ·  Flag as inappropriate

        I have my typing style set as precise and Spacebar will always insert a space. It works ok when entering urls in Evernote or OneNote. The only annoying thing is a period automatically inserts a space so you have to backspace after every dot. I'm not experiencing the suggestion being put in after changing those settings. I'm also running the most recent Beta.

      • kzutterkzutter commented  ·   ·  Flag as inappropriate

        This is SOOO frustrating. The period key inserts the suggestion. No visible way to disable. Typing URLs is fairly common for many of us.

      Feedback and Knowledge Base