What is your SwiftKey bug?

Docked asus transformer prime; / hardkb

latest version of SwiftKey; Norwegian language, Letters æ, ø, å does not work. Same goes for @.These problems only appears when docked, using physical keyboard.
Very annoing having to switch between different keyboard

243 votes
Sign in
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Geir Testad Geir Testad shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    Benjamin GILLET Benjamin GILLET shared a merged idea: non-qwerty dock support  ·   · 
    SimonSimon shared a merged idea: dock / non-qwerty  ·   · 
    PhilPhil shared a merged idea: Since update from ASUS ICS 4.0.3 build9.4.2.21 language choice is non operational (i.e only qwerty keyboard working instead of azerty one)  ·   · 
    Cliff McLoughlinCliff McLoughlin shared a merged idea: Correct operation with Asus Transformer Keyboard so I don't have to switch back to Asus  ·   · 


    Sign in
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      • Tobias DuTobias Du commented  ·   ·  Flag as inappropriate

        Now it is not with certain layouts, but with all non en_EN layouts.
        And its not only happening the transformer tablets, but many tablets with an external bluetooth / usb keyboard.
        So this is a major inconvenience with a large impact.
        Please get this sorted out, we payed for this (at least I thought that this feature is working when i bought swiftkez) (see!)

      • MichalMichal commented  ·   ·  Flag as inappropriate
      • MichalMichal commented  ·   ·  Flag as inappropriate

        I'm not sure if it is problem with Swiftkey. I would say it is problem with Asus Transformer configuration. The same problem is with Asus Transformer Infinity TF700T. If I attach dock (physical keyboard) my layout is changed to english and I can't type polish letters. The only solution is to use EEEpad KLSwitcher (but unfortunately it does not work for Infinity, author has been informed) or you can do it manually (root required, change your language code accordingly):

        - copy /system/usr/xt9/keylayout/qwerty-pl_PL.kl to /system/usr/keylayout/asusdec.kl
        - copy /system/usr/xt9/keychars/qwerty-pl_PL.kcm to /system/usr/keychars/asusdec.kcm

        Reboot and then you will have your own layout plus you will be able to type your national letters using physical keyboard with Swiftkey keyboard enabled.

        Anyway the same issue has been reported in a lot of differents threads with different titles so I would say it is quite critical and should have been already fixed by now.

      • Robert NiemiRobert Niemi commented  ·   ·  Flag as inappropriate

        According to Evan Tapper, work on this started in April. Any progress at all?
        I really find this bug annoying. So anoying in fact that I'm using the default Android keyboard instead. I do like Swiftkey better, but cannot accept to get a non-working keyboard every time I connect the tablet to the dock. (Asus Transformer Prime.)

      • Markus AverstadMarkus Averstad commented  ·   ·  Flag as inappropriate

        I use the swedish keyboard dock, and have the same problem. Would love for there to be a swedish setting for Bluetooth keyboard layout.

        Haven't rooted the thing yet, so can't really do that remap thing suggested.

      • AnonymousAnonymous commented  ·   ·  Flag as inappropriate

        Hi, we actually dont care about +auto detect the keyboard+ cant we just chose a layout in options?

      • Aaron MatthiesenAaron Matthiesen commented  ·   ·  Flag as inappropriate

        Good news for all of you who are having this problem, and whose Transformer is rooted: I found an application on the Play Store that solves the issue for me and makes the experience perfect - just as it should be.
        The app is called EEEpad KLSwitcher and allows to set your dock layout when a soft keyboard is selected. After a reboot it is applied and there's not much you need to think about (apart from the fact that you need root).
        It made my German layout completely German, but I assume it will work just as good for every other language.
        I hope that was helpful and works for everyone.
        [BTW, if there is still something incorrect, go to the SwiftKey settings and set the external keyboard language to English (US) there].

      • Brice ArnouldBrice Arnould commented  ·   ·  Flag as inappropriate

        It's great that your working on this! However so far the fix is only partial. My Transformer has a builtin hardware AZERTY keyboard. It was recognized as a QWERTY keyboard by Swiftkey, so I enabled the Swiftkey option telling that my "bluetooth keyboard" was an AZERTY keyboard. It worked for almost all keys but the "digit" keys of the upper row which still behave as they would on QWERTY keyboard (on an AZERTY keyboard they default to letters unless shift is pressed, with Swiftkey they default to digits and I get the QWERTY symbols if I use shift)

      • AnonymousAnonymous commented  ·   ·  Flag as inappropriate

        Workaround in swiftkey 3 is still not enough for French (azerty) keyboard, despite various bugs reports during beta phase, making it unusable :(

      • RicoRico commented  ·   ·  Flag as inappropriate

        On SwiftKey 3 Tablet Beta you can select Bluetooth keyboard layout. I set this to German and it works great with the german dock keyboard.
        Will buy the final version.

      • Mark AdamsMark Adams commented  ·   ·  Flag as inappropriate

        Agreed. I bought Swiftkey for my phone but if it continues to cause the @ and " to transpose on the keyboard dock of my Transformer Prime then I'm not going to get past the trial of the tablet version.

      • Roland KohnRoland Kohn commented  ·   ·  Flag as inappropriate

        + 1 for swiss german layout. I'm constantly switching back and forth between ASUS and SwiftKey... Btw - SwiftKey word prediction doesn't know its own name ;-)
        I would've already been helped if at least the switching could be done automatically.

      • Geir Testad Geir Testad commented  ·   ·  Flag as inappropriate

        Thank you very much for the invite.

        Made me an account there, but sadly I don't speak or write in any of the supported languages.
        Could try the english one (of course), but that helps very little since the three last letters in my alphabet (æ,ø,å) don't exist in the english alphabet.

        My Prime is now at service, but when I receive it back from the shop I will try.

      • spiralisspiralis commented  ·   ·  Flag as inappropriate

        This STILL hasn\t been fixed. It\s a major problem! It is NOT only for Norwegian letters. It is a problem for ANY user not using US keybord afaik.

        Swiftkey, if anything, you should at least comment on the thread! Please don\t ignore paying users.

        BTW> I apologize on the strange @misspellings@ above, and the at/signs in this sentence, and the slashes in this sentence too. And the greater than symbol. All caused by the Swiftkey bug. More about the problems>, and sorry about the > which should have been a colon...

        / the slash in the it\s is caused by Swiftkey, it should have been an apostrophe. And the / should have been a minus/sign. Ops, there it goes again...

        / the asterix and the start parenthesis should have been start and end parenthesis...

        The bottom line is that I cannot use the product I bought with my Prime Transformer
        I think this post makes that pretty evident...

      • PhilPhil commented  ·   ·  Flag as inappropriate

        Same issue with french version with ICS. It looks like Android keyboard, which cannot been closed, manages this issue...???

      • it's meit's me commented  ·   ·  Flag as inappropriate

        same issue with german version! All special characters are missplaced :-(

      • FoodFood commented  ·   ·  Flag as inappropriate

        Have the same problem with my transformer with dock plugged in
        Keyboard is interpreted qwerty but my phisical layout is azerty
        EVAN could we expect a fix with the forthcomming honeycomb?

      ← Previous 1

      Feedback and Knowledge Base