What is your SwiftKey bug?

Cannot Download Language Pack

First, before a support agent posts a general solution and closes this bug, I have already gone through previous solutions such as deleting app data, deleting and reinstalling the app, rebooting, etc.

I am using Andoid 4.1.1 Jelly Bean (kernel 3.0.31-g396c4df) on a Samsung Galaxy Nexus. My carrier is Verizon Wireless.

Since I updated to Jelly Bean about a month ago, my paid version of Swiftkey 3 cannot download any language pack - the error I receive is "Network Error: Could not download language pack. Please ensure that you have a data connection available (preferably WiFi) in order to continue. You may need to try again later if the network is busy." This same error always occurs, even when I am on a very strong 4G and/or WiFi connection and all other applications work fine.

The error started immediately after updating to Jelly Bean. The trial version does work and can download language packs, but the trial just expired so that is no longer a viable temporary solution.

I have gone through all the typical solutions, including wiping app data, uninstalling, reinstalling, and I have done these multiple times for good measure. Currently, my paid version of Swiftkey 3 is unusable.

I also sent an email to support, on Friday but have yet to receive a response.

140 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    CoreyCorey shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    AugustoAugusto shared a merged idea: Cannot download language pack  ·   · 
    Anonymous shared a merged idea: Language Pack Download failed  ·   · 
    VirginiaVirginia shared a merged idea: can't download Language packs  ·   · 
    completed  ·  SarahAdminSarah (Support Representative, SwiftKey) responded  · 

    We’ve included some improvements to how language pack downloads are handled in SwiftKey 3.1.
    Please update to the latest version – if you are still experiencing trouble please repost with the details.
    Thanks.

    61 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • enzotheresaenzotheresa commented  ·   ·  Flag as inappropriate

        I don't know if it will help you or not, but it helps me. all you need to do is, when you in the language list, press the menu button, and select update languages. after that, you can download your own desired languages. thanks.

      • mediumspinymediumspiny commented  ·   ·  Flag as inappropriate

        I give up. I'm going back to the Google keyboard. This problem has been going on for at least a couple of years form reports I have seen here. Obviously, it is never going to be fixed.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I cannot download language packs either in the paid version or in the trial version. I have deleted and reinstalled several different version of SwiftKey, but NONE of them can download a language pack. The program downloads the pack, and then says it cannot due to a network error. The phone is only a foot away from the wireless access point. I have tried different versions, different access points, no access point, just phone data, all without any success at all. Please fix this. I have a Samsung Exhilerate with Android 4.2.4.

      • AnonymousAnonymous commented  ·   ·  Flag as inappropriate

        I was able to get it to download by plugging my phone into my computer, tethering it and then unplugging it again. After doing this it re-loaded/prepared my SD card and everything downloaded properly. Tried every option available before doing this and it just worked. This was on an HTC One X

      • marcusmarcus commented  ·   ·  Flag as inappropriate

        same Problem with newest version of swiftkey and android 4.2.2

        Any solution for this issue, have the payed version installed :(

      • HippieHippie commented  ·   ·  Flag as inappropriate

        Just downloaded this app and to my surprise it is not working. Just as everyone else has said before, I am having the exact same problem for my HTC EVO 4G Design phone. Before posting I did try all the troubleshooting suggestions listed from both Swiftkey and other users! Any help/assistance to get the app working would be greatly appreciated! Thanks!!

      • Anonymous commented  ·   ·  Flag as inappropriate

        Have a Samsung Galaxy Tab 2 and downloaded Swift key Tablet version. Tried all the tricks mentioned above, can't get it to download US English file. Have free version on SIII, and it works great.

      • InfiniteImpInfiniteImp commented  ·   ·  Flag as inappropriate

        Solved it! Hope this works for someone else. I had the same problem (unable to download/install the language pack) but only after I'd switched from the stock GS3 rom to the LiquidSmooth ROM. Swiftkey had previously installed and worked just fine on the stock rom as well as the AOKP rom.

        What lead me in this direction, funny enough, was the Google email sync. It hit an error (something like "sync is currently experiencing problems."). Googling that error produced a recommendation from Google to make sure there was a data connection and that Airplane mode was turned off. In my case, Airplane mode was indeed off and the data connection worked fine. I was able to use the web, Play store, etc.

        Anyway, I turned Airplane mode ON, waited a few second, then turned it off. Both Google account sync AND Swiftkey 3 now work. I was able to download the language pack and complete the installation of Swiftkey 3. It's almost like Airplane mode was 'partially off' as little sense as that makes.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Found the solution! Just download the SwiftKey 3 Keyboard Free Version . Install and It will start Downloading the Language Pack. Once you download your Language just exit. Don't Continue. Then open SwiftKey 3 Keyboard.Sometime you may get a blank scree. If so just uninstall the free version. Now you can download the Language pack on purchased version.

      • HenryHenry commented  ·   ·  Flag as inappropriate

        getting same issue on my Galaxy S3, it keeps getting a communication error

      • davedave commented  ·   ·  Flag as inappropriate

        Same problem here. Apparently they are getting a lot of people's $$ for a product FAIL !!!

      • Fábio SamjiFábio Samji commented  ·   ·  Flag as inappropriate

        I'm having the same problem since yesterday! This should be fixed already! Samsung Galaxy S2 with CM 10.1

      • Andrew RudyyAndrew Rudyy commented  ·   ·  Flag as inappropriate

        I m using the same android 4.1.1 on Motorola RAZR HD and I m get the same error when I try to download a language pack it doesnt work . I have tried all the troubleshooting mentioned in posts before. It is a played version .

      • KidKid commented  ·   ·  Flag as inappropriate

        Still no luck after trying everything possible. It has now been two months of struggle for me, I'm running the latest version on my Nexus S 4.1.2 and the language pack still won't download. I really don't know what else to do than posting here, and hoping an admin will actually be able to enlighten us all concerning that very annoying issue. Swiftkey is hands down the best keyboard out there and the testimony of an incredible work, but paying for something that you can't actually use can get pretty frustrating.

      • MartínMartín commented  ·   ·  Flag as inappropriate

        Same problem in LG Optimus Black with Android 2.3.4. I´ve updated to the latest version (Swiftkey Flow Beta), by downloading the file to hard drive of my computer from the website of SwiftKey and the problem has been fixed. I write from Spain and my English is not very good. I'm sorry so much.

      • Devon StrydomDevon Strydom commented  ·   ·  Flag as inappropriate

        I am running the latest version of swiftkey 3 and I have uninstalled and reinstalled it. But still nothing. I have paid for the full version,what is the point if I can use it?
        I'm running android ice cream sandwich 4.0.4 on Sony Xperia S.
        Please fix the problem?

      ← Previous 1 3

      Feedback and Knowledge Base