What is your SwiftKey bug?

Keyboard settings "select input method" constantly reappears in notification tray.

Keyboard settings "select input method" constantly reappears in
notification tray.

Comes back if cleared.

Galaxy nexus. Android 4.0.1

http://i.imgur.com/VroFV.png

147 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    ChrisChris shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    WayneWayne shared a merged idea: "Select Input Method" in notification bar  ·   · 
    JohnDJohnD shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Anonymous shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Anonymous shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Anonymous shared a merged idea: "Select Input Method" in notification bar  ·   · 
    peterpeter shared a merged idea: Select Input Method  ·   · 
    Kaitlyn Elizabeth Kaitlyn Elizabeth shared a merged idea: Select Input Method in notification bar  ·   · 
    ErinErin shared a merged idea: Select Input Method in Notification Bar  ·   · 
    MCompeauMCompeau shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Anonymous shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Anonymous shared a merged idea: Select Input Method shows in notification bar  ·   · 
    AshleyAshley shared a merged idea: Choose Input Method in Notification bar  ·   · 
    My InfoMy Info shared a merged idea: Select Input Method in Notification Bar  ·   · 
    Anonymous shared a merged idea: "Select Input Method" in notification bar shows  ·   · 
    Pierre Pierre shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Chris FChris F shared a merged idea: "Select Input Method" shows  ·   · 
    Nicholas MargaritisNicholas Margaritis shared a merged idea: Keeps prompting to select input method  ·   · 
    Matt Volpe Matt Volpe shared a merged idea: "Select Input Method"  ·   · 
    LiLLLiLL shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Erik Kruse Erik Kruse shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Anonymous shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Adam BarryAdam Barry shared a merged idea: "select Input Method" keeps showing  ·   · 
    Anonymous shared a merged idea: 'Select an input method' shows  ·   · 
    May MayMay May shared a merged idea: "Select Input Method" in notification bar  ·   · 
    EmilyEmily shared a merged idea: "select input method"  ·   · 
    Anonymous shared a merged idea: "select input method"  ·   · 
    JustinJustin shared a merged idea: "Select Input Method" shows in notification bar  ·   · 
    HaakonHaakon shared a merged idea: "Select Input Method" in notification bar  ·   · 
    Robert LanuchaRobert Lanucha shared a merged idea: "Select Input Method" notification  ·   · 
    Anonymous shared a merged idea: "Select Input Method" in notification bar  ·   · 
    *Mary Bailey**Mary Bailey* shared a merged idea: "Select Input Method" in notification bar  ·   · 
    PetePete shared a merged idea: Select Swiftkey as input method  ·   · 
    XavarianXavarian shared a merged idea: App keeps asking me to choose a setting,even after ive done so.po  ·   · 
    Anonymous shared a merged idea: keyboard icon in notification bar  ·   · 
    AnonymousAnonymous shared a merged idea: select input method in notification bar  ·   · 
    Anonymous shared a merged idea: Select Input Method in notification bar  ·   · 
    AnonymousAnonymous shared a merged idea: keyboard icon in notification bar  ·   · 
    R.ArredondoR.Arredondo shared a merged idea: Swiftkey keeps popping up several times a day in notifications bar to "configure settings" on my Tmobile Samsung Galaxy S3  ·   · 
    TimTim shared a merged idea: input method notification -ICS  ·   · 
    DanielDaniel shared a merged idea: ICS keyboard Notification bar  ·   · 
    AnonymousAnonymous shared a merged idea: When using swiftkey x there is a notification that says select input method. Galaxy nexus  ·   · 
    Tom Shott Tom Shott shared a merged idea: The swift key notification icon is staying on the notification bar. I have a Infuse.  ·   · 
    declined  ·  Evan TapperAdminEvan Tapper (Admin, SwiftKey) responded  · 

    We don’t have any control over this notification, unfortunately. This is a feature of Android 4.0 and above – it’s not related to SwiftKey. A web search of “select input method ics” will show this to be the scenario.

    If there are multiple keyboards enabled on the device within one’s Settings, this notification will show whenever a keyboard is on screen. If you were to disable SwiftKey completely within your Language & input settings and enable other keyboards along with the stock keyboard, this notification remains.

    128 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Settings> Applications >running > Disable swfitkey or androidkeyboard what ever you choose
        > Rebot

      • ReynaldoReynaldo commented  ·   ·  Flag as inappropriate

        "Just disable the stock keyboard in applications...

        EDIT.. Once you disable "Android Keyboard" in applications, you have to reboot.

        Google Voice Typing is still an option though.. so you may have to disable that too if the notification appears.

        Second edit... after unchecking Google Voice Typing... the language selector is no longer there."

        Source: http://forum.xda-developers.com/showthread.php?t=1723747

      • Anonymous commented  ·   ·  Flag as inappropriate

        Disable all the others including the stock keyboard and the voice input... Then it will be gone..
        Thanks swiftkey for this awesome product.. Just add a few more themes :-)

      • windsorwindsor commented  ·   ·  Flag as inappropriate

        Do you know if there is a way to disable the recently-added Google keyboard? I am not referring to the Android keyboard; it's called Google keyboard on my Galaxy Nexus running Android 4.2.2. Thanks!

      • SimonSimon commented  ·   ·  Flag as inappropriate

        I came here as I was having the same thing happen to me. It it now quite clear...

        THIS IS NOT A PROBLEM WITH SWIFTKEY, IT IS A NEW FEATURE IN ANDROID!

        So please, stop bugging the poor Swiftkey people who have done nothing but give us a great product, go and bug Google instead :)

      • Anonymous commented  ·   ·  Flag as inappropriate

        Yeah, same problem here. It's so annoying. The same notification appears when I go back to using the Samsung Keyboard with SwiftKey enabled, so I gotta disable it first.

      • AliciaAlicia commented  ·   ·  Flag as inappropriate

        This is also a problem with Swipe so it is an android problem. I'm a swipe user and it's driving me nuts. Only started quite recently.

      • Zaki ZulkarnainZaki Zulkarnain commented  ·   ·  Flag as inappropriate

        Same situation here, and it's annoying! Please find a way to solve it! I tracked down this thread and it was happening since 2011?

      • Judy MonroeJudy Monroe commented  ·   ·  Flag as inappropriate

        Oh my gosh, I am so sick of always having to remove the notification that says "select input method". Something has to be done...I don't have good eyesight and always thing I have a message of something important...

      • E littleE little commented  ·   ·  Flag as inappropriate

        If you ignore the icon it disappears after you finish typing. Just because its there doesn't mean you need to reply to it

      • Robert Todd KendellRobert Todd Kendell commented  ·   ·  Flag as inappropriate

        I can confirm that if all other keyboards, including that Samsung keyboard are frozen or removed, then Swiftkey will work without the dialogue.

      • Robert Todd KendellRobert Todd Kendell commented  ·   ·  Flag as inappropriate

        @ct, it appears in your sig that you are on ICS. This is mostly a 4.1.1 problem with Swift key specifically. When I used a custom ROM with 4.1.2 or higher it didn't happen, nor with version 3 of Swift key. I am going to try and uninstall or disable all other keyboards and see if it still happens.

      ← Previous 1 3 4 5 6 7

      Feedback and Knowledge Base