What is your SwiftKey bug?

Voice input hears me, but does not insert any text at all.

On my Droid3, I can use the Voice Input key, but the program no longer inserts the text into the text field. In email, nothing happens. In text messaging, the words appear on the main screen with I back out of the conversation. This is a new issue and I have tried uninstalling and re-installing the app.

233 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    ScottScott shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    Patrick Patrick shared a merged idea: The voice to text feature analyzes my voice but does not fill in the text field.  ·   · 
    AnonymousAnonymous shared a merged idea: Voice recognition works great sometimes, other times it doesn't hear anything at all.  ·   · 
    ChrisChris shared a merged idea: Voice input hear  ·   · 
    completed  ·  Evan TapperAdminEvan Tapper (Admin, SwiftKey) responded  · 

    This issue has been resolved for the vast majority of scenarios. Unfortunately, the original post was somewhat vague. In order for us to serve your needs, please provide us with the following information if you are continuing to have issues:

    1) device
    2) version of Android
    3) version of SwiftKey
    4) custom ROM?
    5) app you’re using SwiftKey in where voice input fails.

    Thanks

    91 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Allan MadarAllan Madar commented  ·   ·  Flag as inappropriate

        I had this problem before, it was fixed by re-installing. That was last year, Now today, voice is not typing in the text. Seems to come and go since I also had this problem a few months ago, I think I reloaded it again too.
        Motorola Droid Maxx
        Android 4.4
        ROM 32GB, RAM 2GB
        Swiftkey Ver 4.4.4.264
        Will not work while texting, but works in Gmail.

      • MarkMark commented  ·   ·  Flag as inappropriate

        Hello. Same issue.
        Samsung Galaxy Nexus (toroplus).
        SlimRom KitKat 4.4.
        SwiftKey 4.4.4.464.
        Stock KitKat Messenger.

        Thanks for looking into it.

      • Fidel AzizeFidel Azize commented  ·   ·  Flag as inappropriate

        I am having exact same issue. A popup from the app comes up asking to 'choose the best match', but when selected, the popup simply closes and nothing gets transposed onto the text box.

        1. Nexus 4
        2. 4.3.1
        3. 4.4.3.262
        4. Slimroms
        5. Messaging

      • Jan StangerJan Stanger commented  ·   ·  Flag as inappropriate

        This is still not working in KitKat on my Moto X. When I'm in the messaging app and try to use the voice input feature, it does not insert the text I dictated.

      • AlanAlan commented  ·   ·  Flag as inappropriate

        mine works fine when I ran Android 4.0 .4, now since it's updated to 4.1 .1 it does not work in less Bluetooth is turned off this is on my samsung galaxy s3

      • Plamen V.Plamen V. commented  ·   ·  Flag as inappropriate

        Still doesnt work for me.

        1) HTC one X quadcore
        2) 4.0.4
        3) 3.0.0.302
        4) stock rom
        5) not working with any messenger

      • MichaelMichael commented  ·   ·  Flag as inappropriate

        Voice input does not insert text. Details as needed from above: Droid Bionic, Android 2.3.4, swiftkey 3.0.0.302, no cust ROM, Only problem is with Browser 2.3.4 and HG Companion 5.00.20. The voice input responds with the correct wording, I choose the wording but it is not input into the field. I do see it appear for a brief second then it disappears. swiftkey voice input works correctly for all other apps. Using the default android multi-touch keyboard, the browser and HG Companion work correctly. Thanks, Keep up the good work!

      • pkongstvedtpkongstvedt commented  ·   ·  Flag as inappropriate

        Having this problem as well. Sent an email to support, but received automated response to use self-service support. I can activate voice recognition and it will provide three choices, telling me to tap on a choice to select it. When I tap on the correct choice, it drops back to the text entry field to the same place it was when I activated voice recognition. I use it mostly with K9 email app and GoSMS app. Had no problem before buying and installing SwiftKey 3.

        I'm using a stock (non-rooted) Verizon HTC Droid Incredible 4G LTE in the U.S. It runs ICS 4.0.3 and HTC Sense versioin 4.0 and HTC Sense Input with SwiftKey 3 keyboard input, SwiftKey version 3 3.0.0.302. Voice Recognizer is Google.

      • Chris LaneChris Lane commented  ·   ·  Flag as inappropriate

        Still doesn't work - hears me, offers suggestions, doesn't insert text:

        New HTC EVO 4G LTE Sprint, stock ROM, Handcent, Android 4.0.3, 3.3.0.0.302

      • SylvanSylvan commented  ·   ·  Flag as inappropriate

        My wife has this issue with HandCent SMS on a stock HTC One S running Android 4.0.3 and Swiftkey 3.0.0.302.

      • KevinKevin commented  ·   ·  Flag as inappropriate

        EVO 4G LTE. Android 4.0.3, most recent update of SwiftKey 3. Not rooted. It doesn't work in any app for me. Just one example would be gosms.

      • Tom ErdelyTom Erdely commented  ·   ·  Flag as inappropriate

        I just tested and an example would be with HandCent SMS or Touchdown. I have an HTC One S running Android 4.0.3. Swiftkey is 3.0.0.302. I am not running a custom ROM. Again, the voice input fails on any non-built-in app. So, it works fine for Gmail, Google Navigation, the HTC Mail app, etc. But does not work for anything that I have downloaded like Waze, HandCent, Touchdown, Chrome, etc. I have reset the phone to factory settings, installed only Touchdown, HandCent and Swiftkey for testing and the issue persists.

      • EricEric commented  ·   ·  Flag as inappropriate

        I'm having this issue on my HTC Incredible 4G LTE. In some applications, SwiftKey refuses to enter text into the text box even though it does give me a choice of what to enter. Other applications just work. Stock keyboard inserts text as I say it but is terrible for typing.

        I'm running ICS. Example of working applications: any.do, noodles. Example of not working: handcent, maps, dolphin, almost everything.

      • Tom ErdelyTom Erdely commented  ·   ·  Flag as inappropriate

        Same problem for me on One S. I love this keyboard, but I use the voice piece all of the time and this is a deal breaker. I wish they would fix it.

      ← Previous 1 3 4 5

      Feedback and Knowledge Base