How can we improve SwiftKey?

Let me disable or override autocompletion.

Let me disable or override autocompletion. If I backspace over a suggestion, it should not come back. I tried to type "Damn" and it was replaced by "Danny" three times. There was no way to type the word I wanted!

73 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Jacqueline A. JonesJacqueline A. Jones shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • César LeivaCésar Leiva commented  ·   ·  Flag as inappropriate

        Same here, no mather how much you try to backspace and correct it, the keyboard will just pop up the same wrong word again. It was REALLY HARD to type some custom words, I ended taping in middle of word to avoid autocomplete and then work my way there, VERY ANNOYING FEATURE!!

      Feedback and Knowledge Base