How can we improve SwiftKey?

turn off autocorrect

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    TomTom shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  Evan TapperAdminEvan Tapper (Admin, SwiftKey) responded  · 

    If you find SwiftKey’s autocorrect to be too aggressive for your liking, you can longpress the 123 in the lower left of the keyboard and change your “Spacebar completion mode” settings to "always insert a space’ withing SwiftKey ’s Advanced submenu.

    33 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        The spacebar-option disables the AutoCOMPLETE feature only. But it's not possible to disable the AutoCORRECTION! I have more work with the annoying re-correction of my words than Swiftkey helps me to save time by auto-correcting me.
        PLEASE make it possible to disable the damn AutoCORRECTION!

      • Maaz Shahid Maaz Shahid commented  ·   ·  Flag as inappropriate

        !!! ATTENTION!!!
        He just told how to turn off auto correct....
        Go to settings of SwiftKey keyboard then to "advanced settings" and change "spacebar completion mode" from "always insert a pridiction" to "always insert a space" .

      • flowflow commented  ·   ·  Flag as inappropriate

        Yes PLEASE add an autocorrect off option! It's driving me nuts!

      • Anonymous commented  ·   ·  Flag as inappropriate

        Spent more than an hour google-ing how to turn off the darn Swiftkey auto correct!. They should not expect that everyone is born gifted in figuring things out by themselves. Anyway enough of the rant & lets move on to the solution, I just updated mine with the latest version & the 123 long press doesn't do the trick anymore. Here's what you do...
        Go to your SwiftKey APP - ADVANCED (Text correction & other settings) - Spacebar completion mode - Always insert a space.

        and Tada! The auto-correct is off ;)

      • WayneWayne commented  ·   ·  Flag as inappropriate

        We really do need the option to turn off swiftkey at times. I use an app called teamviewer to remote control client servers and pc's, logging in typing in a password is excruciatingly difficult. I love the swiftkey everywhere else but when running this selected app.

      • Anonymous commented  ·   ·  Flag as inappropriate

        The lack of a simple autocorrect on/off switch is mind-boggling!!
        Please add it!

      • Anonymous commented  ·   ·  Flag as inappropriate

        I think an easy fix for this would be a complete disable option and timed disable option. For those of us who use the auto-correct most of the time but then run into the cases of needing to insert something that should NOT be auto-corrected (such as a url) you could hit a configurable timed auto-correct hot-key on the keyboard which would disable auto-correct for 30 seconds.

      • Michal GlocMichal Gloc commented  ·   ·  Flag as inappropriate

        Even with the spacebar setting, it still messes up my spelling, as I use 3 languages. As long as swiftkey does not have "completly disable autocorrect/autocomplete" it's unusable for me.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Just stopped using swiftkey after almost a year of use because I cannot disable autocorrect for entering in an URL. The app should be able to tell, duh, that after an "http://"; that it doesn't need to autocorrect but no, and there is no way to enter in the address using swiftkey.

      • RaziRazi commented  ·   ·  Flag as inappropriate

        hold the swiftkey(123) icon in the keyboard -> settings -> advance -> spacebar completion mode ->
        always insert a space ......... Kaboom Done

      • KaosKaos commented  ·   ·  Flag as inappropriate

        I agree about the autocorrect. It is driving me nuts. I hesitate to abandon swiftkey because it is the best keyboard I've found (miss the click click, beloved blackberry keyboard). Make an easy auto correct on/off button AND please please program the arrow for new line to be a send.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I was about ready to throw my phone. Perhaps you should spend less time on the frill and more time on the core of the damn app.
        I sent a simple text, or so I thought...sent another to clarify what had meant to send...then finally a third to fix both of the typos caused by BS auto correct in the first two texts. Thank goodness I have unlimited text messaging.
        Unnecessarily frustrating.

      • Jason JudgeJason Judge commented  ·   ·  Flag as inappropriate

        A simple way to disable it temporarily is needed. I am finding I cannot even enter a domain name into a DNS checker form. I get "Www. Example. Com" - no - that is not a domain name. I cannot see a way to tell SwifyKey to just get out of the way while I type into a box.

      • XmonsterXmonster commented  ·   ·  Flag as inappropriate

        I cannot use the Swiftkey until it has no autocorrect disable in a simple way.
        There is no way to enter a code in an application, the program always corrects it.
        I cannot use nicknames, acronyms at the end of the sentence if it followed by a ! or ?.
        I turn back to the original keyboard...:(

      • Yet Another OneYet Another One commented  ·   ·  Flag as inappropriate

        I echo the comments of the person who wanted an easy way to enable/disable auto correct. I was unable to enter a google search with the correct terms (e.g., mu hu [a Chinese golfer]). Luckily I ran across this thread. However, there are other times/applications where auto correct would be welcomed.

        [BTW - on my version a longpress of the 123 does not work, you need press on the Swiftkey key to the right of the 123]

      • No one importantNo one important commented  ·   ·  Flag as inappropriate

        I am SO glad I found this site. The auto-correct was really ticking me off and I was THIS close to uninstalling the app...which would have ticked me off since I just bought it.

        I agree with others...you need to add a disable auto-correct button.

      • Anonymous commented  ·   ·  Flag as inappropriate

        the spacebar setting is too hidden and vague, and i'm sure a lot of people uninstalled the app before finding it. Need to have a "disable autocorrect" setting

      • FreyGrimrodFreyGrimrod commented  ·   ·  Flag as inappropriate

        Please please add this have run into many things impossible to type rarely even with repeated moving of the cursor. May have to uninstall due to this and purchased it not happy at all.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Please add a disable autocorrect button. SwiftKey often makes really annoying "improvements" to my writing

      ← Previous 1

      Feedback and Knowledge Base